Saturday, September 17, 2011

Running a VMware Site Recovery Manager recovery plan errors out with the message: “Error occurred: Failed to create group image: unknown exception”

Problem

You notice that executing one of your recovery plan errors out at the Prepare Storage step with the message:

Error occurred: Failed to create group image: unknown exception

The logs will show that the step fails instantly:

2. Prepare Storage

Error: Error occurred: Failed to create group image: unknown exception.

00:00:00

    2.1. Attach Disks for Protection Group "Recovery_Plan_Name"

Error: Error occurred: Failed to create group image: unknown exception.

00:00:00

Exporting the VMware Site Recovery Manager logs:

image

… show the following:

[2011-09-08 11:36:09.536 04708 trivia 'SecondarySanProvider'] Found 1 properties for object 'vim.HostSystem:host-43'
[2011-09-08 11:36:09.536 04708 trivia 'SecondarySanProvider'] Found 1 properties for object 'vim.HostSystem:host-45'
[2011-09-08 11:36:09.536 04708 verbose 'SecondarySanProvider'] Found 2 hosts for 4 VMs
[2011-09-08 11:36:10.241 04708 error 'SecondarySanProvider'] Array 'array-4106' already has 'shadow-group-268956' as a dependent
[2011-09-08 11:36:10.242 04708 trivia 'SecondarySanProvider'] 'Prepare storage for group 'shadow-group-268956' for recovery' took 0.72 seconds
[2011-09-08 11:36:10.242 04708 verbose 'PropertyProvider'] RecordOp ASSIGN: info.error, BeginImageTest-10500
[2011-09-08 11:36:10.242 04708 verbose 'BeginImageTest-Task'] Error set to (dr.fault.InternalError) {
[#24]    dynamicType = <unset>,
[#24]    faultCause = (vmodl.MethodFault) null,
[#24]    reason = "Failed to create group image: unknown exception",
[#24]    msg = "",
[#24] }

Solution

One of the reasons why you would experience this error is if vCenter / SRM have problems mounting and dismounting snapshot volumes. There will be times when the clean-up process of a recovery plan test does not complete properly or the array manager’s replication does not clean-up temporary LUNs which will then cause a test process to fail when trying to create a group image. One of the ways to rectify this issue is to try and use the rescan options from within vCenter to automatically refresh the LUNs. The following is what the procedure would look like:

1. Log into vCenter, navigate to hosts and clusters, right click on one of the datacenters and select Rescan for Datastores.

image

2. Repeat this procedure for all of the other datacenters in the protected site and the recovery site.

3. Go through the process of reconfiguring the Array Managers to ensure that there are no errors during the process:

image

image

image

Ensure that initiating a rescan of the arrays does not throw any errors by clicking on the Rescan Arrays button:

image

Hope this provides anyone encountering this error an idea of how to start troubleshooting this problem.

No comments: