Tuesday, September 13, 2011

Could not start OCS 2007 R1 Edge Server Services

Problem

You attempt to start your OCS 2007 R1 Edge server’s services but it throws the following errors:

Service: Office Communications Server Web Conferencing Edge

Error Message:

Could not start the Office Communications Server Web Conferencing Edge service on Local Computer.
Error 10013: An attempt was made to access a socket in a way forbidden by its access permissions.

image

-------------------------------------------------------------------------------------------------------------------------------------------------------------------

Service: Office Communications Server Audio/Video Edge

Error Message:

Could not start the Office Communications Server Audio/Video Edge service on Local Computer.
Error 1068: The dependency service or group failed to start.

image

-------------------------------------------------------------------------------------------------------------------------------------------------------------------

Service: Office Communications Server Audio/Video Authentication

Error Message:

The Office Communications Server Audio/Video Authentication service on Local Computer started and then stopped. Some services stop automatically if they have no work to do, for example, the Performance Logs and Alerts service.

image

-------------------------------------------------------------------------------------------------------------------------------------------------------------------

Service: Office Communications Server Access Edge

Error Message:

Windows could not start the Office Communications Server Access Edge on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code -1008124830.

image

-------------------------------------------------------------------------------------------------------------------------------------------------------------------

The Office Communications Server Logs show the following events being logged:

Event ID: 12326

Description:

Failed starting the protocol stack. The service has to stop

Error code is:0xC3E93C62 (SIPPROXY_E_NO_DEFAULT_OUTGOING_CERT).

Cause: Check the previous entries in the event log for the failure reason.

Resolution:

Try restarting the server after resolving the failures listed in the previous event log entries.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

image

-------------------------------------------------------------------------------------------------------------------------------------------------------------------

Event ID: 14352

Description: 

Unable to start the stack.

Error: 0x0xC3E93C62 (SIPPROXY_E_NO_DEFAULT_OUTGOING_CERT).

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

image

-------------------------------------------------------------------------------------------------------------------------------------------------------------------

Event ID: 14368

Description: 

Unable to start key manager (Error: 0x0xC3E93C62 (SIPPROXY_E_NO_DEFAULT_OUTGOING_CERT)).

Cause: This can happen if the server has insufficient privileges to access the certificate store. This can also happen if the certificate is not valid.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

image

-------------------------------------------------------------------------------------------------------------------------------------------------------------------

Event ID: 14397

Description: 

A configured certificate could not be loaded from store. The serial number is attached for reference.

Extended Error Code: 0x800B0101.

Cause: This could happen if the certificate is not found or if the server has insufficient privileges to read and/or access the store containing the certificate.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

image

Here’s what the flow of events in the logs look like:

image

Solution

The reason why the Edge services are not able to start is because the certificate the interfaces (public and internal) have expired.

Notice that one of the events logged actually specifies the serial number of the certificate.

image

To correct the problem, simply renew or replace the expired certificates with valid ones, assign them to the Edge server’s interfaces and restart the Edge services.

No comments: