Saturday, January 26, 2013

Installing VMware vSphere Client 5.0 on Windows 8 fails with: “This product can only be installed on Windows XP SP2 and above”

Wanting to be an early adopter of Windows 8, I went ahead and upgraded my laptop over the weekend and one of the first issues I immediately noticed was when I attempted to install the VMware vSphere Client 5.0 (VMware-viclient.exe) where it would fail with the following message:

This product can only be installed on Windows XP SP2 and above

image

image

Having come across similar issues in the past with previous new Windows desktop operating systems, I went ahead and opened up the properties of the VMware-viclient.exe executable:

image

Navigated to the Compatibility tab, checked Run this program in compatibility mode for then selected Windows 7 from the drop down menu:

image

Once I made this change, the installation completes successfully:

image

image

4 comments:

Notes email archiving said...

I am still on win7 but in few months i will try win8,good guide for vmware!

melodicmatt said...

I did the same as above, except I had to pre-install Visual J# and .NET 3.5 beforehand; the VIclient installer did not want to play nice.

Damion said...
This comment has been removed by the author.
Damion said...

I tried your suggestion on a windows 8.1 install. I used windows 8 as the compatibility mode instead of windows 7. That failed but I was notified of the failure and it asked if I wanted to run it in compatibility mode. I answered yes and the install proceeded with no problems. I assume the install would have worked properly the first time if I had chosen windows 7 as the compatibility mode.