Thursday, March 19, 2015

Attempting to launch VMware SRM plug-in throws the error: “The server ‘192.168.155.10’ could not interpret the client’s request. (The remote server returned an error: (404) Not Found.)”

Problem

You’ve recently upgraded vCenter from 5.1 to 5.5 and quickly noticed that you receive the following error when attempting to load Site Recovery Manager:

Connection Error: Lost connection to SRM Server 192.168.155.10:8095

The server ‘192.168.155.10’ could not interpret the client’s request. (The remote server returned an error: (404) Not Found.)

image

Lost connection to remote SRM server at 192.168.155.10:8095.(The server ‘192.168.155.10’ could not interpret the client’s request. (The remote server returned an error: (404) Not Found.))

image

Solution

The reason why this error is thrown is because there is a mismatched in version between vCenter and Site Recovery Manager. Note that the screenshot below shows that the version for vCenter is 5.5.0.43769 while SRM is 5.1.1.7655:

image

To correct this issue, use the VMware Product Interoperability Matrixes to determine what version of SRM supports the installed vCenter then proceed to upgrade the VRA (if it is used) and then SRM:

image

No comments: