Sunday, September 14, 2014

Citrix XenApp 7.5 Site Setup fails when creating a new database

Ran into an interesting issue the other day that was easy to fix but noticed that the error message could be misleading so I thought it would be a good idea to write a blog post in case other encounter this.

Problem

You’re setting up a new Site in XenApp / XenDesktop Studio and would like the wizard to create a new database so you proceed with filling in the database server location and database name as such:

image

You then hit the Test connection button:

image

You receive the prompt:

No database was found on the database server.

To create a database automatically, click OK.

Or, if you would prefer to use the database schema to create a database, click Cancel.

image

You proceed to hit OK to allow the wizard to create a new database:

image

… but notice that you are prompted with the following message:

The current credentials have insufficient privileges to access the database server and perform the necessary operations. Do you wish to enter alternative credentials?

image

You are sure that you’ve logged onto the server to run this wizard with an account that has permissions but go ahead and type in the credentials again:

image

After typing the credentials and hitting the OK button, you are prompted with the same message:

The current credentials have insufficient privileges to access the database server and perform the necessary operations. Do you wish to enter alternative credentials?

image

Solution

What I noticed after a bit of troubleshooting was that the firewall on the SQL server was turned on and as soon as I disabled the firewall, the wizard proceeded:

image

It’s definitely a bit strange that the message would indicate an issue with the account when it’s related to the firewall but I hope this post would serve up a quick answer to those who encounter this.

No comments: